Technics 1200MK2, problem w/ platter spining
  English Topics, DO NOT reply in other languages than English !  

Twitch    posted on 04-08-2007 03:50
so i just bout an mk2 and i did becuse i have heard wonderful things about them, i bought it used becuse it is cheaper, it was working fine when i was checking it out and messing around with it, but now i have gotten it home and the platter will not spin, after i turn it on as soon as i hit start, it just sort of rocks back and forth, none of the lights flicker or anything, and the power remains on. has anyone ever seen anything like this or ever had anything like this happen to them? if so what did you do? can it be fixed and if so is it any easy fix or is it going to cost a good deal to do?

Luxx    posted on 04-08-2007 10:17
sounds like its jamming or something. if you are handy you should try and open te SL and try to fix it yourself. other solution is to go to a certified dealer
www.mothermusic.nl
Lead    posted on 04-08-2007 11:58
If your sure that there is nothing underneath the platter it must be a technical mallfunction.

Does this describe the problem :

All LED's light up as usual, popup light is lit when popped out but the balls in the stroboscoop are 'bouncing' or at least not moving in a fluid direction.

If so : a problem might be in the drive control IC or in any of the electronics that sync the speed. This can only be solved by a technician who kows what he does. There is nearly nothing you can do when you have a slim knowledge of technical electronics.
Let the BASS be louder

Create your FREE ACCOUNT now !

Using an account on DJResource has a lot of advantages such as:
Adding Content, getting Notifications, Like content, Downloading and Uploading Images and much more.

 Sign Up

Create your account to get involved with the Community



79 Users online: 4 Guests (75 Unknown)*
Pages generated today : 7.182
Most users online this month : 265
Lifetime Pageviews : 191.599.058